Ubuntu Compiz Fusion on ati mobility 7500, with different issues

2013-12-15  Source: Original Site  Category:Ubuntu  Views:0 

Advertisement

I got a little different issue with ait mobility 7500 on my compiz fusion. It looks like in most siutation, compiz just work out of the box with 7500. Here is the message I got:

compiz --replace
xset: unable to open display ""
xdpyinfo: unable to open display "".
xvinfo: Unable to open display
xdpyinfo: unable to open display "".
xdpyinfo: unable to open display "".
xdpyinfo: unable to open display "".
xdpyinfo: unable to open display "".
xdpyinfo: unable to open display "".
xdpyinfo: unable to open display "".
Fatal: Failed test: texture_from_pixmap support
Checks indicate that it's impossible to start compiz on your system.

I wouldn't even find the identical error on google. Basically, I'm using the tradditional radeon driver with agpmode 4, and glx and dri module. There are the 2 important session of my xorg file, hope it can be a little bit help.

If anybody has a clue of what it goes wrong, please do let me know. Million of thanks.

Cheers,

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "dbe"

Load "GLcore"
Load "radeon"
Load "xtrap"
Load "drm"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility M7 LW [Radeon Mobility 7500]"
Driver "radeon"
BusID "PCI:1:0:0"
Option "XAANoOffscreenPixmaps"
Option "AGPMode" "4"
Option "RenderAccel" "true"
Option "AGPFastWrite" "true"
Option "EnablePageFlip" "True"
Option "UseInternalAGPGART" "no"
Option "backingstore" "true"
Option "AllowGLXWithComposite" "true"
EndSection

Related articles
  • Ubuntu Compiz Fusion on ati mobility 7500, with different issues 2013-12-15

    I got a little different issue with ait mobility 7500 on my compiz fusion. It looks like in most siutation, compiz just work out of the box with 7500. Here is the message I got: compiz --replace xset: unable to open display "" xdpyinfo: unable to ope

  • Ubuntu compiz fusion xgl ati...HELP! 2015-02-03

    there! I've got a fresh install of 7.04, (ignoring the ati driver in restricted) I installed "Envy" to sort out the driver for my graphics card, ATI radeon 9600 XT. I ran Envy, "uninstalled ATI driver" then "installed ATI driver".... that all seemed

  • Ubuntu Compiz-Fusion on ATi X 1550 2015-05-05

    For the last few days I have been desperately trying to run Compiz Fusion on Ubuntu 8.4 with an ATi X 1550 graphics card. I have installed Xgl and the Compiz advanced effect settings program. Every time I try to install a driver after I reboot after

  • Ubuntu Compiz-Fusion on ATI 200M 2013-02-18

    I have been using beryl in XGL on my machine with an ATI 200m graphics chip. I had to use this guide to get it to work: http://ubuntuforums.org/showthread.php?t=399643 I now want to install the new compiz-fusion. However, there is a mixture of how-to

  • Ubuntu hardware conflict of ATI mobility 5470 with intel HM57 chipset? 2013-10-24

    Yesterday I met a critical problem when doing routine work under Ubuntu desktop 10.04 on my laptop. That is: Suddenly, the screen seems no-responding, and pressing Ctrl-Alt-F1 could not let me enter Terminal mode. I had to hard-reboot the laptop. The

  • Ubuntu Compiz Fusion w/ ATI and Envy 2013-11-30

    I followed the tutorial to install compiz-fusion from here (http://kevin.vanzonneveld.net/techblog/article/enable_compizfusion_in_ubuntu_feisty/) and I am having some trouble getting it to work. When I run compiz --replace I get: [email protected]

  • Ubuntu Compiz Fusion on ATi 2015-05-14

    I've been trying for a week now to get a good guide to install compiz fusion on my (very old) desktop, which I'm using as a media centre, becuase the new desktop is my main one. Anyway... it has an ATi X600 graphics card. the system is i386. Is there

  • Ubuntu Compiz-Fusion Not Totally Cubical Even With Correct Setup 2012-05-30

    Hey, ive gotten compiz fusion working, on most aspects. The two things that dont work completely ok are the next ones: The 3d desktop doesnt take the shape of a cube, even if there are four desktops enabled. Screenies: Enabled 4 desktops - http://i16

  • Ubuntu Compiz Fusion for ATI cards + Xgl in Feisty error! 2013-05-04

    i get this error when i run the following [email protected]:~$ compiz --replace Fatal: Failed test: texture_from_pixmap support Checks indicate that it's impossible to start compiz on your system. [email protected]:~$ i have looked everywhere for the solution ha

  • Ubuntu Compiz-Fusion Slow Window Resize and Screen Resolution issues 2014-09-05

    This is my first time using Ubuntu or any Linux distro. I'm running gutsy on a AMD64 with a Radeon 9800. I already installed the ATI drivers and have emerald and compiz-fusion installed and working except for after attempting to resize any window thi

  • Ubuntu Compiz Fusion and ATI??? 2012-08-01

    Hello, I have an ATI X200 mobile chipset on my laptop. Well I don't know how I did it but I have the ability to run effects!!!!! was there an update to Gutsy as that is what I am running to allow this? I installed xserver-xgl (i believe that is the p

  • Ubuntu IBM ThinkPad T42 ATI Mobility 7500 Driver 2013-11-25

    Hi, I am very new to Ubuntu and linux. I installed Ubuntu 8.10 2 days ago and searched a package for ATI Drivers and installed it, that did not work and it forced me to low resolution 800-600. I simpley reinstalled Ubuntu and now i am back to the gen

  • Ubuntu Dell Inspiron 5100 ATI Mobility 7500 driver issue (Low graphics mode.) 2015-03-24

    Hello, I am hoping to make a complete reference for people with this laptop in the newest 8.10 version of ubuntu. All my google searches end up with people having 7.04 issues, etc. Anyway, it seems like this computer, via the alternate install, goes

  • Ubuntu Compiz Fusion in Feisty: Only problem with window borders 2012-09-08

    Okay, this isn't your typical "no window borders" problem... experienced that before and fixed it. Right now the window borders are like a transparent black shade and kind of ugly. Anyway, can't figure out how to change them. If I activate window bor

  • Ubuntu HELP WITH ATI MOBILITY 7500 drivers! I am stressssssed! 2013-12-12

    Ok so I installed Gutsy a couple of days ago and i tried 3-4 different how-to's to get my ATI Mobility 7500 working right. I read some forums and found out gutsy doesn't work so well but alot of people had good 3d acceleration with Feisty. So this mo

  • Ubuntu Need help with ati mobility 7500 2015-03-07

    I've been working with Ubuntu for about 3 weeks now with my IBM t40. So far I have been pretty successful in getting all the devices functioning properly, thanks to the people that have been kind enough to post in these forums. My problem is that I s

  • Ubuntu Thinkpad R40 ATI Mobility 7500 video problems! HELP! 2014-03-08

    I am having a bit of a problem getting video drivers to work properly. I installed Hardy 8.04 and have the run the system updates. I get good resolution, but I would like to be able to use visual effects and hardware acceleration. I have a Thinkpad R

  • Ubuntu Compiz Fusion Cube Caps - can't get images 2012-05-02

    I've been sifting through the forum looking for a thread that handles my issue, but no luck. I know from my searching that this is a pretty frequently handled issue, but mine is... unique? I just did a clean install of Hardy Heron a few weeks ago, an

  • Fedora 8 / Xorg 7.3 - VT switch yields all-white LCD on ATI Mobility 7500 2012-09-02

    I have a laptop (Compaq Evo N1000v) with a graphics card of ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] with 32MB memory. I'm running Fedora 8, and the auto-installed X driver is "radeon". My problem is that whenever I switch fr

  • Ubuntu Compiz Fusion Dead After Clean Install 2012-11-17

    Before my clean install of Ubuntu, Compiz Fusion worked great. Not one single crash. However, now, no matter what I do (uninstall everything compiz related, remove old repos, then reinstall with new repos) CF will just not work. Lspci: 00:00.0 Host b