Ubuntu Boot failure after running update-initramfs

2012-03-14  Source: Original Site  Category:Ubuntu  Views:0 

Advertisement

Here is an interesting problem. Two systems, both running 10.04.2 LTS, fail to boot (hang in the "ubuntu" screen) after an update via apt-get.

The following files worked fine:
initrd.img-2.6.32-21-generic
initrd.img-2.6.32-26-generic
initrd.img-2.6.32-27-generic

However, after manually running "update-initramfs -u", the initrd.img file size goes from 8.3MB to 14.1MB. Restoring the system requires booting from a CD, mounting the hard disk file system, and copying back in the old version of initrd.img, but it would be really nice to be able to update these systems.

Both systems are running encrypted file systems, one with one encrypted partition and the other with two encryptped partitions, which were installed by geneally following the out-of-date documentation on the https://help.ubuntu.com/community/EncryptedFilesystemOnIntrepid page, plus working around these missing files in the sample /etc/initramfs-tools/scripts/local-top/cryptoroot script:
/etc/console-setup/boottime.kmap.gz
/sbin/usplash
/sbin/cryptsetup
/bin/chvt

That script now looks like this:PREREQ="udev"

prereqs()
{
echo "$PREREQ"
}

case $1 in
# get pre-requisites
prereqs)
prereqs
exit 0
;;
esac

if [ -f /etc/console-setup/boottime.kmap.gz ]
then /bin/loadkeys -q /etc/console-setup/boottime.kmap.gz
fi
modprobe -qb dm_crypt
modprobe -qb sha256_generic

# The following command will ensure that the kernel is aware of
# the partition before we attempt to open it with cryptsetup.
if [ -x /sbin/udevadm ]
then
/sbin/udevadm settle
sleep 5
fi

if [ -x /bin/chvt ]
then
if grep -q splash /proc/cmdline
then
/bin/chvt 1
sleep 2
fi
fi

/sbin/cryptsetup luksOpen /dev/sdb1 cryptodisk
sleep 2

if [ -x /sbin/usplash ]
then
if grep -q splash /proc/cmdline
then
/sbin/usplash -c
sleep 2
fi
fi

# ----- end of file ----- #

Is something in the setup for the encrypted file systems causing initrd.img to be re-built improperly?

Related articles
  • Ubuntu Boot failure after running update-initramfs 2012-03-14

    Here is an interesting problem. Two systems, both running 10.04.2 LTS, fail to boot (hang in the "ubuntu" screen) after an update via apt-get. The following files worked fine: initrd.img-2.6.32-21-generic initrd.img-2.6.32-26-generic initrd.img-2.6.3

  • Ubuntu boot failure after kernel update 2014-02-19

    Its getting so i do not suggest ubuntu to my friends. It started several months ago on my tower. After a kernel update ubuntu would not boot. So found this procedure using the live update cd. Update grub.cfg & delete everything down to but not in

  • Ubuntu Boot failure after Bios update - GRUB 2012-05-17

    I have a dual boot system Ubuntu 9.10 and Win XP. Yesterday I updated the BIOS and restarted the system. Computer booted and instead of showing the Grub boot selection screen it just said wrong system stuff and insert or change to proper boot device.

  • Ubuntu Boot failure after removing disk 2012-12-12

    Hi I installed Ubuntu 7.10 on my second hard drive (hdb) and kept WinXP on the first one (hda), Install went smooth and I had dual boot functionality with GRUB and Ubuntu was working well. I decided to remove my WinXP harddrive completly from the sys

  • Ubuntu Boot Failure after Sleep 2012-01-14

    I encountered a serious problem of boot failure in my Lucid system. It was after the sleep and the machine became not accessible when I pressed the power button. Then I gave it a full power up and it can not boot. The error message is the following D

  • Ubuntu Boot Problem After Auto Update 2012-03-26

    After Auto Update, Dell D630 doesn't boot properly. Running Lucid 10.04 for a month or so. I can boot from F12 one-time menu to InternalHD, system works fine. On normal boot, I just get a blinking cursor upper left, but nothing happens after that. #

  • Ubuntu Multiple errors after running 'update' 2014-02-05

    I get a list of errors after running: sudo apt-get update The following errors occur after update runs: Fetched 198B in 1s (184B/s) W: GPG error: http://packages.medibuntu.org karmic Release: The following signatures couldn't be verified because the

  • Ubuntu boot issues after todays update. 2014-05-07

    Just about 4 hours ago, I updated ubuntu software using the update manager in Gnome. I primarily use Gnome but I also have the kde-desktop installed. But after todays update, I am unable to log back into Linux. First of, I am missing windows OS in th

  • Ubuntu Boot Failure after installation from 6.10 live cd 2014-05-29

    I downloaded the 6.10 live cd and it worked perfectly on the machine amd 1.2ghz Installed ubuntu with all default options. The installation completed sucessfully and requested a reboot. After reboot it appears the system can not find the hard drive /

  • Ubuntu Boot problems after kernel update 2014-06-19

    I have had ubuntu installed on my machine for one year now, and upgraded to Hardy last month without problems. A couple of days ago the update manager informed me that there were new updates. I installed them; on of them was a kernel update to 2.24.1

  • Ubuntu boot problem after Gnome update 2015-05-17

    I recently downloaded the new update for ubuntu (Im pretty sure that the new gnome is in there) but after the update he asked me to do restart, after i restarted the computer ubuntu gave me this screen http://img95.imageshack.us/img95/4536/0285oa.jpg

  • Ubuntu Lost sound after running update 2015-04-02

    My sound was working then after I restarted after the update application I had no sound. I installed the gstreamer codecs and tried different programs but none of them produce any sound. There are no errors, just no sound plays. Also I have a somewha

  • Ubuntu Boot failure after updates...."Gave up waiting for root..." 2013-01-13

    After some auto-updates Ubuntu 9.04 will not boot (hard disk partitioned, Windows XP still boots ok). Tried booting from CD, unsuccessful. Excuse me but I am inexperienced and unfamiliar with the Linux lingo: I get to to the screen which lists the Ub

  • Ubuntu Boot failure after recent kernal update 2012-01-18

    I've updated Feistry with the recent kernal, and now the system completely fails to boot. I've had this problem coming I suppose, but here is the main issue: On booting, I get the following error messages appear: Check root= bootarg cat /proc/cmdline

  • Ubuntu boot failure after update - debconf? 2012-08-12

    I just installed updates for my computer. There were a lot of them so I don't know what was updated. It asked if I wanted to do something with debconf. Something about keep the original or change to the package managers? Anyways, I selected package m

  • Ubuntu Boot failure after botched kernel update 2013-07-27

    So I ran the update manager to install the latest kernel. It goes fine and was sitting at the restart prompt. I was playing minecraft and the entire system locked up - couldn't restart X or anything. Hard restart and I get a multitude of errors mostl

  • Ubuntu Boot error after kernel update or no splash 2012-03-04

    After updating the kernel image to linux-image-2.6.15-20-powerpc in an iBook G4, the system does not boot because of this bug (https://launchpad.net/distros/ubuntu/+source/initramfs-tools/+bug/32123). Booting a previous kernel, I could create a new i

  • Ubuntu Boot problems after regular update Natty programmes 2012-04-13

    Haven't found anyone on the forums with a similar problem, so starting this thread for advice. I have been happily running natty/unity on a macbook 2,1 for a couple of months now. Occasional glitches but no major issues. After last regular update (Ju

  • Ubuntu Boot problem after installing updates 2012-09-22

    Ubuntu 7.10, kernel 2.6.22-14-generic Today I installed some updates from the automatic update manager. After installing them there was message to restart my computer. After restarting the computer the grub menu appears OK and the Ubuntu splash scree

  • Ubuntu Boot Failure After Loading Splash Screen 2013-12-05

    New to Xubuntu here, switched from Ubuntu 8.04 because my memory was too low (or I don't know how to control my swap usuage). Running: Distro: Xubuntu 9.04 Laptop: Dell Inspiron 9300 Processor: 1.02Ghz Memory/RAM: Supposedly 512mbs, but when I switch