Ubuntu Apt-repositories problem - cannot find packages

2013-12-20  Source: Original Site  Category:Ubuntu  Views:0 

Advertisement

I have a problem with the apt-get command. If I try to install for example either msttcorefonts, sun-j2re1.5, acroread or nvu, i only get a message similar to this:

[email protected]:/etc/apt # apt-get install nvu
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package nvu
[email protected]:/etc/apt #

or this:

[email protected]:/etc/apt # apt-get install msttcorefonts
Reading package lists... Done
Building dependency tree... Done
Package msttcorefonts is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package msttcorefonts has no installation candidate
[email protected]:/etc/apt #

or this:

[email protected]:/etc/apt # apt-get install acroread
Reading package lists... Done
Building dependency tree... Done
Package acroread is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
mozilla-acroread acroread-plugins
E: Package acroread has no installation candidate
[email protected]:/etc/apt #

My sources.list looks like this:

# deb cdrom:[Ubuntu 5.04 _Hoary Hedgehog_ - Release i386 (20050407)]/ hoary main restricted

deb http://no.archive.ubuntu.com/ubuntu hoary main restricted
deb-src http://no.archive.ubuntu.com/ubuntu hoary main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://no.archive.ubuntu.com/ubuntu hoary-updates main restricted
deb-src http://no.archive.ubuntu.com/ubuntu hoary-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://no.archive.ubuntu.com/ubuntu hoary universe
deb-src http://no.archive.ubuntu.com/ubuntu hoary universe

deb http://security.ubuntu.com/ubuntu hoary-security main restricted
deb-src http://security.ubuntu.com/ubuntu hoary-security main restricted

deb http://security.ubuntu.com/ubuntu hoary-security universe
deb-src http://security.ubuntu.com/ubuntu hoary-security universe

# Diverse
deb http://ubuntu-backports.mirrormax.net/ hoary-backports main universe multiverse restricted
deb http://ubuntu-backports.mirrormax.net/ hoary-extras main universe multiverse restricted

# deb ftp://ftp2.caliu.info/backports/ hoary-backports main universe multiverse restricted
# deb ftp://ftp2.caliu.info/backports/ hoary-extras main universe multiverse restricted

I have of curse done several apt-get update commands.

Related articles
  • Ubuntu Apt-repositories problem - cannot find packages 2013-12-20

    I have a problem with the apt-get command. If I try to install for example either msttcorefonts, sun-j2re1.5, acroread or nvu, i only get a message similar to this: [email protected]:/etc/apt # apt-get install nvu Reading package lists... Done Building depen

  • Ubuntu apt-get : could not find package k9copy 2012-01-06

    Was iniatally thinking of installing wine and dvdshrink, but on the Ubuntu pages I got the clear understanding that is the last resort to try. I was then recommended to get hold of K9copy for 6.06. I then entered command as desribed: [email protected]:~$ s

  • Ubuntu apt-get "couldn't find package" 2012-01-08

    I have the following problems with installing a number of commands via apt-get. I've successfully installed samba and rdiff-backup so simetimes it works. What should I do next? [email protected]:/home/trad# apt-get install rsnapshot Reading package li

  • Ubuntu apt-get Couldn't find package vsftpd 2012-09-07

    Hello, when i was reading 2 tutorial pages on how to install vsftpd and they both said type sudo apt-get install vsftpd. but this is the output:Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find

  • Ubuntu error... cannot find package 2014-09-28

    I did some searching in this forum and I've tried everything in the HOWTO and in the discussions and I still have this issue. I'm using 6.06. When I issue this command: [email protected]:~$ sudo apt-get install fakeroot java-package java-common I get th

  • Ubuntu Tomcat Install Problem: Cannot find catalina.sh 2013-12-03

    I followed the Tomcat installation instructions in this thread: http://ubuntuforums.org/showthread.php?t=44006 However, when I try to start Tomcat, I get this error: "Cannot find /usr/local/tomcat/bin/catalina.sh" I looked in the directory and the fi

  • Ubuntu apt-get can't find package 2012-06-15

    I am trying to cross compile ffmpeg with mingw by following this guide. http://ffmpeg.arrozcru.org/wiki/index.php?title=Main_Page It uses some packages that are hosted here: http://apt.arrozcru.org/ You can see there is a package mingw32-w32api on th

  • Ubuntu Uninstalling when you cannot find package in package manager 2014-04-25

    I've got an install of Xampp which I want to re-install due to lost privileges I cannot seem to find another way around. Xampp does not appear in the "add/remove" package manager found Applications menu. I've looked for it in the advanced Synaptic Pa

  • Ubuntu mysql connector problem cannot find class com.mysql.jdbc.Driver 2013-11-18

    I am using Ubuntu 7.04. I installed mysql5.0. I wrote a java program to connect to the mysql database. The code is: import java.sql.*; //import java.util.Properties; public class DBconnect { // The JDBC Connector Class. private static final String dr

  • Ubuntu File install problem, cannot find it anywhere! 2012-02-24

    I installed 4 things so far on the ubuntu. I used wine for 3 of them and ubuntu installed the 3rd one. 1 of the programs I installed with WINE is in the accessories bar under the WINE category with it the other 2 are not. Where do my programs go once

  • Ubuntu Synaptics cannot find packages 2014-10-29

    I just did a fresh install of 9.10. Began to add packages. Installed the Medibuntu repository and it seems OK. But, Synaptics cannot find packages like w32codecs, etc. I did install via console but Synaptic cannot find the installed package even. It

  • Ubuntu 10.10 Cannot Find Packages 2014-01-22

    Hello, I just recently installed Ubuntu on an older computer of mine to boost it's performance, and have some fun with the open source OS. Upon installation, I discovered Ubuntu could not find my wireless card and tried to install NdisWrapper to reme

  • Ubuntu Motherboard upgrade - boot cannot find drives - G43 problem? 2012-05-27

    First some background: My old motherboard died (Intel platform G31 chipset?) and I temporarily swapped it for an AMD platform board. This machine runs 8.04. My new motherboard came in (G43 chipset) and I swapped it into the system. Now the boot proce

  • Ubuntu New installation: apt-get can't find packages 2012-08-24

    I recently installed 7.10 Gutsy Gibbon. When trying to install packages I'm getting error messages: [email protected]:~$ sudo apt-get install tcsh Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find pa

  • Ubuntu apt-get can't find my package 2013-12-16

    Hi. Brand new to Ubuntu, came from Gentoo. I'm trying to install a package, libpam-pwdfile. apt-get doesn't find the package, nor can I see it listed if I use dselect. However, the package does seem to be in the Ubuntu source tree (see (http://packag

  • Ubuntu apt-get can't find any packages 2015-04-16

    I have done two fresh installations of ubuntu 9.04, a few days apart, off the same CD. On my first machine I have since installed many additional packages, either via direct use of apt-get or via synaptic. On the newest machine, apt-get can't find an

  • Ubuntu Can't instal J2SDK - apt-get can't find packages 2015-05-08

    When trying to update apt-get (in order to instal J2SDK) I get the following message: http://ubuntu-backports.mirrormax.net hoary-backports/main Packages 404 Not Found Err http://ubuntu-backports.mirrormax.net hoary-backports/universe Packages 404 No

  • Ubuntu virtualbox guest addition problem -- cannot find GNU Make 2012-04-07

    Hi I downloaded the virtualbox non OSE from the SUN's site. I installed and configured it everything is working fine. I installed opensuse using virtualbox. The problem is that when I try to install the virtualvox guest addition I get an error saying

  • Ubuntu apt-get problem, wants to reinstall package that's not there 2012-04-28

    after installing (or trying to install) jedit I now get this error: [email protected]:~$ sudo apt-get remove jedit Reading package lists... Done Building dependency tree... Done E: The package jedit needs to be reinstalled, but I can't find an ar

  • Ubuntu apt-get unable to find any packages 2013-04-30

    Hi I just installed Hardy. Upon trying to install various packages via apt-get (e.g. "sudo apt-get install texlive-latex-recommended") I keep getting the error message "Couldn't find package". However, If I attempt to install the same packages with S