Cannot import pygame for python 2.6

2012-09-08  Source: Original Site  Category:Python  Views:0 

Advertisement

I installed successfully, it is in python26/Lib/site_packages but it won't import. Here's the error message:

>>> import pygame

Traceback (most recent call last):
File "<pyshell#0>", line 1, in <module>
import pygame
File "C:\Python26\lib\site-packages\pygame\__init__.py", line 93, in <module>
from pygame.base import *
ImportError: DLL load failed: The specified module could not be found.

It's really annoying... I'm using Vista

Related articles
  • Cannot import pygame for python 2.6 2012-09-08

    I installed successfully, it is in python26/Lib/site_packages but it won't import. Here's the error message: >>> import pygame Traceback (most recent call last):File "<pyshell#0>", line 1, in <module>import pygameFile "C:\Python2

  • Ubuntu Need help with pygame for python 2.6? 2012-07-07

    Whoever can help, I just recently purchased both Beginner's Python and Programming Python and wanted to start making games. I am still having problems, even though I have around 2 yrs experience with C++ and .NET . If anyone has any suggestions or ad

  • Problem with importing pygame 2012-03-01

    I am new to Python and I am trying to import pygame. I am using Python 3.1 and I installed pygame 1.9.1 for python 3.1. When I try to import the module I get the following message: Traceback (most recent call last):File "<pyshell#0>", line 1, i

  • Ubuntu PlayOnLinux claims it cannot import wxversion when it is installed 2012-03-27

    I'm trying to get PlayOnLinux up and running on my computer. I have previously had it running with no problems at all, but now it claims it cannot import wxversion when I know for a fact that I have it installed. I have searched Google and UbuntuForu

  • I cannot import 2012-06-20

    I have just started Python recently and for some reason, I cannot import anything on my computer. I can do it on the computer at my school, but not my laptop. This is the message I received when I tried to import the program "cTurtle" IDLE 2.6.1 >

  • Ubuntu Ming for Python 2012-08-20

    I'm trying to get the Ming SWF library for Python installed on Ubuntu, but when I try importing ming in python I get this error: >>> import ming Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/li

  • Problems With Pygame With Python 3.1 2013-01-26

    Greetings, Ok I have finally join over to the linux side of the computing world. I'm running Ubuntu 10.10 on my PC. Anyways, I have been spending a lot of time installing packages for python and pygame. I got the latest, 1.9 installed, along with 2.7

  • Ubuntu Obexftp for Python, building from source 2013-07-04

    I'm building obexftp from the source however I'm having a few issues with it. I'm using the obexftp-0.22-rc6 at the moment, since the 0.20 has a few bugs in it. The reason why I'm not using the obexftp in the repository is due to the fact I can't fin

  • Ubuntu ImportError: cannot import name sessionmaker 2014-11-05

    This is my first attempt at compiling something. ...While writing this post, I think I discovered the problem, but I still need help fixing it. The read me says: Prerequisites: 1. A recent python (2.4 should be fine) 2. libqt4.2+ 3. python-qt/pyqt 4.

  • Ubuntu Using import with Stackless Python 2015-02-09

    Something strange has been happening: First, in the python 2.5.2 interpreter, import pygame fails after working fine since I first installed it, along with several other major python modules like gd and cairo. The standard python libs still worked, l

  • Ubuntu PyGame for Python3 2015-02-20

    Is PyGame available for Python3? I tried doing sudo apt-get install python-pygame but... ~$ python3 Python 3.1.2 (r312:79147, Sep 27 2010, 09:45:41) [GCC 4.4.3] on linux2 Type "help", "copyright", "credits" or "license" for more information. >>

  • Oracle Cannot import script 2012-01-17

    Hi, I have these commands I need them to be entered in SQL Worksheet but I cannot import as a script and cannot execute more than one line at a time at "Enter SQL Commands". Filename: Demobld.sql. Error that comes up when importing: Your export file

  • regular expression for python 2012-02-28

    I've been tearing my hair out for 2 days over this, hopefully someone here can help me. I'm trying to scrape the price data off the following webpage: http://www.morningstar.co.uk/UK/snap...&id=F0GBR04S4X The value I want currently stands at 6.19

  • DistilleryException (Cannot create JVM for JavaUdop, return code is '-1') 2012-04-17

    I've got the following problem when using a JavaUdop: DistilleryException (Cannot create JVM for JavaUdop, return code is '-1') at 'DPS::BIOP_CountEvents::Invoker::Invoker(long int, const std::string&)' [BIOP_CountEvents.cpp:249] Spade:Applicatio

  • error C3121: cannot change GUID for class 2012-06-15

    I am porting some old VC 6 project to vs studio 2005. There are these two import below in the stdafx.h #import "..\select.dll" no_namespace #import "..\label.dll" no_namespace And it ended up with this compile error: x:\debug\label.tlh(20) : error C3

  • Ubuntu cannot import name QtCore 2012-11-19

    I am trying to upgrade to fcronq to v 0.3.0. I get the following error. Any help is appreciated. Ralph [email protected]:~/Documents/Download_folder/fcron_fcronq/fcronq-0.3.0/FcronQ/Build$ make Traceback (most recent call last): File "/usr/lib/pytho

  • Ubuntu Can't launch Spyder,IDE for Python 2013-01-17

    Hi, I have been using spyder for Python. After upgrading from 10.10 to 11.04, I am not able to use this. On launch it gives me this output in terminal. ~$ spyder Traceback (most recent call last): File "/usr/local/bin/spyder", line 4, in <module

  • cannot import System.Data 2013-02-26

    I cannot import the namespace "System.Data" If i use Imports System.Data in my vb file, i get the following error Namespace or type 'Data' for the imports 'System.Data' cannot be found. Whats the problem, please help me. any settings needed in .Net f

  • Ubuntu Installing pygame in python 3.. Help please. 2013-03-11

    I'm a 'new' convert to Linux and have been running Ubuntu 9.10 at home. I recently decided to try and teach myself Python, and bought the Head First Programming book. The programs/code used there use python3, but my ubuntu's standard install is pytho

  • Ubuntu scipy "cannot import name optimize" error 2013-07-14

    I installed scipy and numpy from source to my ubuntu 10.04. I have a weird error. When I run python interpreter I can simply do without error: from scipy import optimize I have a sample fitting program called sinusfit, which imports optimize. Here is