AUDIO CAPTURE PROBLEM ON ARM PB926EJ-s board, Audio couldn't capture on the ARM Board

2012-11-01  Source: Original Site  Category:Linux  Views:0 

Advertisement

Iam unable to capture any audio using my versatile PB926
board running on linux 2.6.21 kernel.The playback function
is working correctly.Though i have verified that the
capture feature has been supported in the AACI driver
aaci.c, iam unable to get any sound recorded using the
microphone. iam able to record and playback sound using a
simple non-os based driver i had written. so there is no
hardware related problems.

i have set the values of line, mic, vol using setmixer. All
have been set to high.

Also, when do a cat /dev/dsp >/var/tmp.wav, the aaci.c
driver calls the aaci_pcm_capture_start() and
aaci_pcm_capture_stop() functions.

#cat /proc/asound/devices
0: [0] :control
16: [0-0]:digital audio playback
24: [0-0]:digital audio capture
33: timer

would appretiate any help in this regard

Fazlur Rahaman Naik,

Related articles
  • Ubuntu Sound Card Isn't recognized: on board audio default on install 2013-01-10

    Asus P5B Deluxe Core 2 Duo 6400 2GB 7600 GT 512mb M-Audio Audiophile 2496 (ice1712) I'm starting to be bugged because I can't seem to get to the bottom of a very basic issue. I'm a musician and podcaster. I've been trying to get Ubuntu to recognize m

  • Ubuntu Linux Audio - Back to the drawing board? 2014-04-07

    First we had OSS - a fairly capable sound system but with a lack of hardware support - so ALSA was draughted in. ALSA gave OSS support, near zero latency but regrettably lacked any kind of sound server. So some individuals came up with PulseAudio...

  • Ubuntu 9.10 ISO audio sync problems 2014-10-09

    So I just upgraded my 9.04 to 9.10 and I am having audio sync problems on all my iso images. audio speeds up and slows down but is never in sync. These are all iso images that worked fine before the upgrade. Any clues what the fix may be?

  • Ubuntu Kino 1.3.0 importing DV tape audio syncing problem 2013-03-28

    I am relatively new to Ubuntu and have virtually transferred my day to day use from Windows to Ubuntu. :) Now whilst I have managed to get everything I want from Vista either running under wine or finding an opensource alternative, Kino is my main pr

  • Ubuntu Audio input problem with JACK and Behringer UCG102 guitar link 2012-01-08

    EDIT Appears to be working now. Will mark as solved once I am confident it won't go away. Hi, I have a problem getting sound into the computer with JACK and the Guitar Link (which I got partly because it was mentioned as well-supported hardware on th

  • Ubuntu Kino & Firewire video capture problems 2012-03-28

    I have a problem with Kino and video capturing. If I start to capture video, Kino crashes within a few seconds. I browsed around the forums but couldn't find anything useful. I'm not sure if it is Kino or firewire problem, but I get the video on Kino

  • Problem with Mu-Law in USB Audio 2012-08-04

    Problem Description – Unable to capture audio from USB Audio Device when the format is set to MuLaw. Scenario – We developed USB Audio Device that produces Audio in MuLaw Format. The USB descriptors are correctly set to indicate that the Audio format

  • Ubuntu Audio/recording problems 2013-04-22

    Hello, I'm completely new to Ubuntu and overall really like it for all purposes other than one: I'm a musician and can't record anything at a halfway decent quality. I've searched this forum for possible solutions for the past 2 months to no avail. I

  • Ubuntu Inspiron 1525 n Audio recording problem 2013-06-19

    I've been trying to record some audio with audacity from FireFox as it plays...(not stealing, from an open source "Philharmonia orchestra site"..check it out)... I'm trying to record through the headphones into the mic jack..(through the output into

  • Ubuntu strange audio feedback problem 2014-02-16

    This is a copy of a post I made to LinuxQuestions.org, which has gotten no response there after a week. I also tried web searches and chatted with someone at qunu, to no avail. I'm hoping someone here will be able to give me a clue. I installed Ubunt

  • Ubuntu On Board Audio Being Disabled In Bios 2014-07-16

    I have a dual booting hp pavilion 7950. Whenever I boot into Ubuntu my sound card stops working but not just in Ubuntu, also in windows XP. I have found that if I go into the BIOS that the "On Board Audio" option is disabled. I can enable it and it w

  • Ubuntu aMSN sound capture problem 2015-03-10

    I have a weird problem with AMSN : I can't capture sound from my webcam, a Quickcam Communicate STX. I'm under Ubuntu 8.10. In Ubuntu, System/Preferences/Sound, I set the sound capture to the USB sound device. When I use the Sound Recorder, the sound

  • Ubuntu audio input problem for Gizmo Project 2012-01-10

    I'm using Edgy and have tried installing Gizmo Project. Installed the gizmo project and bonjour debian file from their website. I've already created a new account with Gizmo Project. Problem is every time I log on I get stopped at the 'starting agent

  • Ubuntu VLC audio sync problems 2012-01-28

    Is anybody noticing that VLC has had audio sync problems since Natty? With nearly every video, I have to delay the audio by about 300ms so that it's in sync with the video. I did a fresh install of Oneiric yesterday, hoping that the updated VLC/kerne

  • Audio Device Problems 2012-08-25

    there, I got some CDs full of Tracks... How I can copy those tracks to HDD... My CD Player dodn't got that cable connected to the sound board. So I can't lisen AUDIO CDs... I am running Windows 2000... what can I do ? Can somebody tell me any softwar

  • Ubuntu disabling on board audio on m59sli-s5 2012-09-14

    trying to uninstall the on board audio card for the gigabyte m59sli-s5 i cant seem to figure out how to do it in bios no clue it doesn't have the ability, so is there a way for me to ignore it??? or blacklist it???:confused: so that way i can do my s

  • Audio link problem 2013-01-19

    Help please!:confused: I am having trouble getting an audio link to work on my site using RealPlayer. When clicking on the link, the player is successfully opened but I then get an error message from RealPlayer saying "Unsupported document type". I h

  • Ubuntu audio delay problem with 0.22 (HDPVR) 2013-02-16

    Before 0.22, I used a custom script to dump video from my HDPVR1212 as a mp4 and mythtv played the files without any problem. http://github.com/jettero/videodump-pl Now that 0.22 supports the HDPVR, it's nice for the program guide and searching funct

  • Ubuntu Mythbuntu 9.10 Weird audio & control problems 2013-03-08

    first of all, mythbuntu is very nice, and I really enjoy all the features. But I'm having some really strange problems. First I'll list the hardare, then the software, then the problem. Please help!! Myth Backend: Asus MB P4 1.9Ghz 4Gb Ram All media

  • Ubuntu Problem with VLC 1.1.4 audio 2013-03-25

    I'm using VLC 1.1.4 from the n-muench/vlc ppa on 10.04 x64. Everytime I happen to pause a video/audio file, the audio stream does not play again upon resuming the file. To get audio back again, I have to go to audio preferences and toggle audio devic